lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Busch <busch...@gmail.com>
Subject Re: "ant test" no longer sees lib/junit-3.8.2.jar?
Date Mon, 10 Nov 2008 01:44:35 GMT
strange... when I run this on a fresh svn checkout all tests finish 
successfully:
  ant -nouserlib -noclasspath clean test

I'm using MacOS and I also tested windows before I committed 
LUCENE-1440. What OS are you running on and what's your ant version? 
(mine is 1.7.0)

-Michael

Michael McCandless wrote:
>
> Mark Miller wrote:
>
>> Michael McCandless wrote:
>>>
>>> Is anyone else seeing this?
>>>
>>> If I run "ant test" it fails saying it can't find the junit jar.  If 
>>> I manually add to CLASSPATH, or run "ant -lib XXX", it works.
>>>
>>> Maybe LUCENE-1440 (ability to run core tests from an SVN tag -- very 
>>> cool) cause this?
>>>
>>> Mike
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
>>> For additional commands, e-mail: java-dev-help@lucene.apache.org
>>>
>> Isn't that what Grant saw during the 2.4 release? : 
>> http://markmail.org/message/jbwju3tkbbpq65z2
>
>
> That issue is that a source dist fails to include the junit JAR (which 
> reminds me we need to get that fixed for 2.9 -- thanks!).
>
> But what I'm seeing is different: from an source checkout "ant test" 
> now fails, unless you manually put the junit JAR on your classpath.
>
> Mike
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message