lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LUCENE-1366) Rename Field.Index.UN_TOKENIZED/TOKENIZED/NO_NORMS
Date Sun, 07 Sep 2008 18:52:44 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-1366?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael McCandless updated LUCENE-1366:
---------------------------------------

    Attachment: LUCENE-1366.patch

OK, this patch switches over all uses of the old names to the new ones.

I plan to commit in a day or two.

> Rename Field.Index.UN_TOKENIZED/TOKENIZED/NO_NORMS
> --------------------------------------------------
>
>                 Key: LUCENE-1366
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1366
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 1.9, 2.0.0, 2.1, 2.2, 2.3, 2.3.1, 2.3.2
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 2.4
>
>         Attachments: LUCENE-1366.patch, LUCENE-1366.patch
>
>
> There is confusion about these current Field options and I think we
> should rename them, deprecating the old names in 2.4/2.9 and removing
> them in 3.0.  How about this:
> {code}
> TOKENIZED --> ANALYZED
> UN_TOKENIZED --> NOT_ANALYZED
> NO_NORMS --> NOT_ANALYZED_NO_NORMS
> {code}
> Should we also add ANALYZED_NO_NORMS?
> Spinoff from here:
>     http://mail-archives.apache.org/mod_mbox/lucene-java-user/200808.mbox/%3C48a3076a.2679420a.1c53.ffffa5c4%40mx.google.com%3E
>     

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message