lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: TestPayloads FAILED?
Date Sat, 17 May 2008 03:48:14 GMT
Hi Mike,

Yes, that fixed it - I ran the test a number of times now and it passed every time.  Thanks.

Otis
--
Sematext -- http://sematext.com/ -- Lucene - Solr - Nutch


----- Original Message ----
> From: Michael McCandless <lucene@mikemccandless.com>
> To: java-dev@lucene.apache.org
> Cc: Otis Gospodnetic <otis_gospodnetic@yahoo.com>
> Sent: Friday, May 16, 2008 10:00:14 AM
> Subject: Re: TestPayloads FAILED?
> 
> 
> Otis, could you try the attached patch?
> 
> I just changed the test to consistently correct invalid UTF16 sequences.
> 
> Mike
> 
> 
> 
> Otis Gospodnetic wrote:
> > Mike, yeah, I just got the test to fail a few more times and then  
> > pass once.  I *think* the expected vs. was output was slightly  
> > different in different failed runs, so it might be that random bit  
> > that's the culprit
> >
> > java.nio.charset.Charset.defaultCharset().name() gives me "UTF-8"  
> > on my JVM:
> > $ java -version
> > java version "1.6.0_03"
> > Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
> > Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)
> >
> > Otis
> > --
> > Sematext -- http://sematext.com/ -- Lucene - Solr - Nutch
> >
> >
> > ----- Original Message ----
> >> From: Michael McCandless 
> >> To: java-dev@lucene.apache.org
> >> Sent: Wednesday, May 14, 2008 3:59:01 AM
> >> Subject: Re: TestPayloads FAILED?
> >>
> >>
> >> I can't get this testcase to fail.
> >>
> >> I've got in running over and over on Win XP / JRE 1.4 and OS X / JRE
> >> 1.5 and haven't seen a failure.
> >>
> >> Otis what are the specs of your laptop?
> >>
> >> Hmm, actually, looking at that test, it generates a random byte
> >> sequence as the payload and then builds a String from that byte
> >> sequence using the default charset.  This is actually risky because
> >> it's entirely possible this would randomly generate an invalid UTF16
> >> string, which could cause that exact failure.
> >>
> >> Otis what's the default charset for the JRE (OS) on your laptop?
> >>
> >> Mike
> >>
> >> Otis Gospodnetic wrote:
> >>> Hi,
> >>>
> >>> Is this just me?  I have not run unit tests in a loooong time and
> >>> when I tried tonight this failed twice in a row.  I don't recall
> >>> any mentions of this on the ML, plus we are not getting nb failure
> >>> emails... just me and my laptop?
> >>>
> >>>     [junit] Testcase: testThreadSafety
> >>> (org.apache.lucene.index.TestPayloads):   FAILED
> >>>     [junit] expected:<[?]��> but was:<[�]��>
> >>>     [junit] junit.framework.ComparisonFailure: expected:<[?]��>
> >>> but was:<[�]��>
> >>>     [junit]     at
> >>> org.apache.lucene.index.TestPayloads.testThreadSafety
> >>> (TestPayloads.java:514)
> >>>     [junit] Test org.apache.lucene.index.TestPayloads FAILED
> >>>
> >>> Thanks,
> >>> Otis
> >>> --
> >>> Sematext -- http://sematext.com/ -- Lucene - Solr - Nutch
> >>>
> >>>
> >>> -------------------------------------------------------------------- 
> >>> -
> >>> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> >>> For additional commands, e-mail: java-dev-help@lucene.apache.org
> >>>
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> >> For additional commands, e-mail: java-dev-help@lucene.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> > For additional commands, e-mail: java-dev-help@lucene.apache.org
> >


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message