lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DM Smith <dmsmith...@gmail.com>
Subject Re: Lingustically-enhanced indexing for Lucene
Date Fri, 09 May 2008 14:28:38 GMT
Steven A Rowe wrote:
> Hi Felipe,
>
> On 05/09/2008 at 8:06 AM, fsanchez@dlsi.ua.es wrote:
>   
>> On the other hand, it is java 1.5 compatible. Even
>> developments in contrib, that are rather independent, 
>> must be java 1.4 compatible?
>>     
>
> Actually, the policy is now that code in contrib can be java 1.5 (or 1.4) compatible.
 The 1.4 compatibility requirement applies only to non-contrib code.  (Note to self: fix the
HowToContribute page to note this fact.)

At this point isn't Java 1.4 compatibility a moot point? IIRC, the plan 
is to "quickly" move to a 2.9 release in preparation for 3.0 which will 
be Java 5. I would think that anything new would wait for 3.0, since 
that is "any day now" :)

Former advocate for Java 1.4,
    DM Smith

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message