lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doron Cohen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1062) Improved Payloads API
Date Fri, 23 Nov 2007 16:08:43 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1062?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545071
] 

Doron Cohen commented on LUCENE-1062:
-------------------------------------

I find Payload.getPayload() a bit confusing - how about renaming Payload methods from:
       setPayload(byte[] data),  setPayload(byte data[], int offset, int length),   getPayload()
to:
       setData(byte[] data),  setData(byte data[], int offset, int length),   getData()


> Improved Payloads API
> ---------------------
>
>                 Key: LUCENE-1062
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1062
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Analysis
>            Reporter: Michael Busch
>            Assignee: Michael Busch
>            Priority: Minor
>             Fix For: 2.3
>
>         Attachments: lucene-1062.patch
>
>
> We want to make some optimizations to the Payloads API.
> See following thread for related discussions:
> http://www.gossamer-threads.com/lists/lucene/java-dev/54708

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message