lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject variuos IndexReader methods -- was: Re: [jira] Updated: (LUCENE-832) NPE when calling isCurrent() on a ParallellReader
Date Wed, 01 Aug 2007 08:17:07 GMT

is it just me, or does it seem like the base class versions of
getVersion(), isOptimized(), and isCurrent() in IndexReader should all
throw UnsupportedOperationException?

(it seems like ideally they should abstract, but that ship/API has sailed)


: This patch fixes ParallelReader similar to LUCENE-781:
:
:    * ParallelReader.getVersion() now throws an
:      UnsupportedOperationException.
:
:    * ParallelReader.isOptimized() now checks if all underlying
:      indexes are optimized and returns true in such a case.
:
:    * ParallelReader.isCurrent() now checks if all underlying
:      IndexReaders are up to date and returns true in such a case.



-Hoss


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message