lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Harwood (JIRA)" <>
Subject [jira] Commented: (LUCENE-584) Decouple Filter from BitSet
Date Thu, 09 Aug 2007 23:15:43 GMT


Mark Harwood commented on LUCENE-584:

OK, I appreciate caching may not be a top priority in this proposal but I have live systems
in production using XMLQueryParser and which use the existing core facilities for caching.
As it stands this proposal breaks this functionality (see "FIXME" in contrib's CachedFilterBuilder
and my concerns over use of  unthreadsafe Matcher in the core class CachingWrapperFilter)

I am obviously concerned by this and keen to help shape a solution which preserves the existing
capabilities while adding your new functionality. I'm not sure I share your view that support
for caching can be treated as a separate issue to be dealt with at a later date. There are
a larger number of changes proposed in this patch and if the design does not at least consider
future caching issues now, I suspect much will have to be reworked later. The change I can
envisage most clearly is expressed in my concern that the DocIdSet and DocIdSetIterator services
I outlined are being combined in Matcher as it stands now and these functions will have to
be separated.


> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Priority: Minor
>         Attachments: bench-diff.txt, bench-diff.txt, Matcher1-ground-20070730.patch,
Matcher2-default-20070730.patch, Matcher3-core-20070730.patch, Matcher4-contrib-misc-20070730.patch,
Matcher5-contrib-queries-20070730.patch, Matcher6-contrib-xml-20070730.patch, Some
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message