lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] Commented: (LUCENE-584) Decouple Filter from BitSet
Date Thu, 23 Aug 2007 05:56:31 GMT


Hoss Man commented on LUCENE-584:

I, unfortunately, haven't had the time to read through everything in the latest patches, but
catching up on my jira mail one of Paul's comments jumped out at me, so i wanted to make sure
it's completley clear: this latest set of patches completely breaks backwards compatibility
for any clients who have Filter subclasses, or methods that take a Filter as a param, since
the Filter class now has an abstract getMatcher method and no longer supports an abstract
BitSet method -- presumably the expectation being that all client code should have a search/replace
done from Filter=>BitSetFilter

which begs the question: why not eliminate BitSetFilter and move it's getMatcher impl to the
Filter class?  (if the concern is just that there be a "higher level" class in which both
methods are abstract, why not insert a parent with some new name above the Filter class?)

For the record: it really bothers me that the old attachments got deleted ... the inability
to refresh my memory by looking at the older patches and compare them with the current patches
is extremely frustrating

> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Priority: Minor
>         Attachments: bench-diff.txt, bench-diff.txt, Matcher1-ground-20070730.patch,
Matcher2-default-20070730.patch, Matcher3-core-20070730.patch, Matcher4-contrib-misc-20070730.patch,
Matcher5-contrib-queries-20070730.patch, Matcher6-contrib-xml-20070730.patch, Some
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message