lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Ingersoll <gsing...@apache.org>
Subject [VOTE] Migrate Lucene to JDK 1.5 for 3.0 release
Date Fri, 27 Jul 2007 00:36:39 GMT
I  propose we take the following path for migrating Lucene Java to  
JDK 1.5:
1.  Put in any new deprecations we want, cleanups, etc.
2. Release 2.4 so all of Mike M's goodness is available to 1.4 users  
within the next 2-4 weeks using our new release mechanism (i.e code  
freeze, branch, documentation.  I tentatively volunteer to be the RM,  
but hope someone will be my wingman on it).
3. Announce that 2.9 will be the last version under JDK 1.4
4. Put in any other deprecations that we want and do as we did when  
moving from 1.4.3 to 1.9 by laying out a migration plan, etc.
5. Release 2.9 as the last official release on JDK 1.4
6. Switch 3.0-dev to be on JDK 1.5, removing any deprecated code and  
updating ANT to use 1.5 for source and target.
7. Start accepting JDK 1.5 patches on 3.0-dev

If possible, efforts should be made to identify people who are  
willing to backport 3.x changes to JDK 1.4 on 2.9 and give them  
branch commit rights, but this is not a strict requirement of this plan.

Thus:

+1 for JDK 1.5 as outlined in steps 1-7
0 if you don't care
-1 if you are against it

Since the weekend is coming up, how about we leave this vote open  
until Monday?

You can see discussions of this here: http://www.gossamer-threads.com/ 
lists/lucene/java-dev/51421

Here is my +1.

Cheers,
Grant

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message