lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Tests, Contribs, and Releases
Date Thu, 17 May 2007 18:02:02 GMT

: In fact I would rename current target "test" to "test-core"
: and make a new target "test" which depends on both "test-core"
: and "test-contrib". That way during developing you can run
: "test-core" - that should be quicker. But the nightly and the

i'm certianly on board with that ... i would have suggested it but i
wasn't sure if people liked the idea of targets they are use to suddenly
getting a lot more complicated.

from a semantic equivilence standpoint, we could also:
 1) rename "test" as "test-core"
 2) create a new deprecated "test" that just depends on "test-core" (but
    has no description so we do't advertise it)
 3) create a new "test-all" that depends on "test-core" and "test-contrib"
 4) replace all current dependencies on "test" with "test-all"

...but it's probably not really worth it unles someone cares strongly
about "ant test" meaning the same thing it always has.


-Hoss


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message