lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] Commented: (LUCENE-584) Decouple Filter from BitSet
Date Thu, 15 Mar 2007 18:08:09 GMT


Hoss Man commented on LUCENE-584:

It's been a while since i looked at this issue, but it's come up in discussion recently so
i took another glance...

Paul: I notice Filter.getMatcher returns null, and IndexSearcher tests for that and uses it
to decide whether or not to iterator over the (non null) Matcher, or over the BitSet from
Filter.bits.  is there any reason that logic can't be put in getMatcher, so that if subclasses
of Filter don't override the getMatcher method it will call bits and then return a Matcher
that iterates over the set Bits?

(this is the roll-out approach i advocated a while back when discussing this on email, excecept
that at the time Matcher was refered to as SearchFilter:

Thinking about it now, we could even change Filter.bits so it's no longer abstract ... it
could have an implementation that would call getMatcher, and iterate over all of the matched
docs setting bits on a BitSet that is then returned ... the class would still be abstract,
and the class javadocs  would make it clear that subclasses must override at least one of
the methods ... legacy Filters will work fine because they'll already have a bits method,
and people writing new Filters will see that bits is deprecated, so they'll just write a getMatcher
method and be done.

This appears to be the same approach taken with Analyzer.tokenStream back in 1.4.3...

> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Priority: Minor
>         Attachments:, Filter-20060628.patch, HitCollector-20060628.patch,
IndexSearcher-20060628.patch,,, Matcher20070226.patch, Scorer-20060628.patch,
Searchable-20060628.patch, Searcher-20060628.patch, Some,,
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message