lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doron Cohen <>
Subject Re: NewIndexModifier - - - DeletingIndexWriter
Date Thu, 08 Feb 2007 19:36:00 GMT
Otis Gospodnetic wrote:

> It's a temporary name, no?  In the end we probably want to keep the
> _name_ IndexWriter, so why not just it IndexWriter2 and when we are
> happy with it, we make it be the new IndexWriter and we deprecate IW2.

For a temporary solution it seems good. But do you also mean releasing
2.1 with IW2? If so we need to javadoc very clearly that this is very
probably a temporary class.

Otherwise -

Chris Hostetter wrote:

> if it's not possible to make this class replace IndexModifier, then
> DeletingIndexWriter or BufferedDeletingIndexWriter seem like they would
> fine to me.

I prefer shorter names (when they are clear enough).
BufferedDeletingIndexWriter seems quite long.
Since IndexWriter too is buffering added documents, seems
it is mostly the deletion that distinguishes the two.

So my preference is DeletingIndexWriter.


Michael McCandless wrote:

> Long-ish term I think we should aim for one reader class (IndexReader)
> that you use to do read-only things and one writer class
> (NewIndexModifier being closest to this now) to make changes (adds,
> deletes, optimize, etc.) to an index.

This sounds great. But at least one use case may no long be possible this
way: there are probably applications 'out there' deleting documents in
this logic: search the index, examine returned docs - post-processing
them using some app-specific logic not well encapsulated in the index,
select a few, delete them by id.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message