lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doron Cohen (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (LUCENE-813) leading wildcard's don't work with trailing wildcard
Date Tue, 27 Feb 2007 19:35:06 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-813?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doron Cohen resolved LUCENE-813.
--------------------------------

       Resolution: Fixed
    Fix Version/s: 2.2
    Lucene Fields: [Patch Available]  (was: [Patch Available, New])

Thanks for reviewing this Michael!

Commited, with few additional wildcard queries in TestWildcard..testParsingAndSearching().


> leading wildcard's don't work with trailing wildcard
> ----------------------------------------------------
>
>                 Key: LUCENE-813
>                 URL: https://issues.apache.org/jira/browse/LUCENE-813
>             Project: Lucene - Java
>          Issue Type: Bug
>            Reporter: Hoss Man
>         Assigned To: Doron Cohen
>             Fix For: 2.2
>
>         Attachments: 813.fix.lead.wildcard.patch, qp-leading-wildcard.patch
>
>
> As reported by Antony Bowesman, leading wildcards don't work when there is a trailing
wildcard character -- instead a PrefixQuery is constructed.
> http://www.nabble.com/QueryParser-bug--tf3270956.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message