lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doron Cohen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-804) build.xml: result of "dist-src" should support "build-contrib"
Date Thu, 15 Feb 2007 08:03:08 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-804?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12473316
] 

Doron Cohen commented on LUCENE-804:
------------------------------------

This can be easily fixed like this:

Index: build.xml
===================================================================
--- build.xml   (revision 507610)
+++ build.xml   (working copy)
@@ -37,7 +37,7 @@

   <patternset id="src.dist.patterns"
               includes="src/,build.xml,*build*.xml,docs/,*.txt,contrib/,"
-              excludes="contrib/*/lib/,src/site/build/"
+              excludes="contrib/db/*/lib/,contrib/*/ext-libs/,src/site/build/"
   />
   <patternset id="binary.build.dist.patterns"
               includes="${final.name}.jar,${demo.war.name}.war,${demo.name}.jar,docs/,contrib/*/*.jar"

A nicer fix would be to also modify contrib/db to have ext-libs rather than lib (like gdata),
but 
for not holding 2.1 this is good enough I think. 

Running "ant -Dversion=2.1.0 dist dist-src" like this and unpacking the src.zip, reults in
the same content as a clean "svn co" (except for the unwanted index.html").

> build.xml: result of "dist-src" should support "build-contrib"
> --------------------------------------------------------------
>
>                 Key: LUCENE-804
>                 URL: https://issues.apache.org/jira/browse/LUCENE-804
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: Other
>    Affects Versions: 2.1
>            Reporter: Doron Cohen
>            Priority: Minor
>             Fix For: 2.1
>
>
> Currently the packed src distribution would fail to run "ant build-contrib".
> It would be much nicer if that work.
> In fact, would be nicer if you could even "re-pack" with it.
> For now I marked this for 2.1, although I am not yet sure if this is a stopper.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message