lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: System Requirements
Date Sat, 09 Dec 2006 15:00:40 GMT
I would say Ant 1.6.5 is the minimum Ant version.  It's a year and a  
half old already, and 1.7RC1 is out now too.  And for JUnit, version  
3.8.1 would be my recommended minimum version.

	Erik


On Dec 9, 2006, at 9:27 AM, Grant Ingersoll wrote:

> Is it documented anywhere what the minimum ANT version is?  I have  
> some updates for the clover coverage (via Michael Busch) stuff and  
> I want to make sure I am not using newer ANT features then we  
> support.  I think it is 1.6.0 right?
>
> In fact, is it safe to say we have the following minimum requirements:
> Java 1.4.x
> ANT 1.6.0
> Junit 3.x (for running tests)
>
> Contrib modules may have other requirements.
>
> Do we have a minimum memory requirement?  Do we claim to support J2ME?
>
> I can find the appropriate place to add these to the docs (probably  
> a new page System Requirements under the Resources section with  
> links from Developers and Releases sections)
>
> Thanks,
> Grant
>
> --------------------------
> Grant Ingersoll
> Center for Natural Language Processing
> http://www.cnlp.org
>
> Read the Lucene Java FAQ at http://wiki.apache.org/jakarta-lucene/ 
> LuceneFAQ
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message