lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eks Dev (JIRA)" <>
Subject [jira] Updated: (LUCENE-584) Decouple Filter from BitSet
Date Mon, 04 Sep 2006 21:03:24 GMT
     [ ]

Eks Dev updated LUCENE-584:

    Attachment: Some

Here are some Matcher implementations,

- OpenBitsMatcher- the same as the code Paul wrote for BitsMatcher, with replaced OpenBitSet

-DenseOpenBitsMatcher  - Using solr BitSetIterator (for skipTo() to work, one method in BitSetIterator
should become public)

Also attached one simple  test (just basic fuctionality) that also contains one dummy relative
performance  test 

Perf. test simply iterates over different Matcher implementations  and measures ellapsed time
(not including Matcher creation, pure forward scan to the end) for different set bit densities.

imho, this code is not sufficiantly tested nor commented, needs an hour or two.  

As expected, Yonik made this ButSetIterator really fast. What was surprise for me was OpenBitSet
nextSetBit() comparing bad to the BitSet  (or I made some dummy mistake somewhere?)

> Decouple Filter from BitSet
> ---------------------------
>                 Key: LUCENE-584
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: 2.0.1
>            Reporter: Peter Schäfer
>            Priority: Minor
>         Attachments:, Filter-20060628.patch, HitCollector-20060628.patch,
IndexSearcher-20060628.patch,,, Matcher20060830b.patch, Scorer-20060628.patch,
Searchable-20060628.patch, Searcher-20060628.patch, Some,,
> {code}
> package;
> public abstract class Filter implements 
> {
>   public abstract AbstractBitSet bits(IndexReader reader) throws IOException;
> }
> public interface AbstractBitSet 
> {
>   public boolean get(int index);
> }
> {code}
> It would be useful if the method =Filter.bits()= returned an abstract interface, instead
of =java.util.BitSet=.
> Use case: there is a very large index, and, depending on the user's privileges, only
a small portion of the index is actually visible.
> Sparsely populated =java.util.BitSet=s are not efficient and waste lots of memory. It
would be desirable to have an alternative BitSet implementation with smaller memory footprint.
> Though it _is_ possibly to derive classes from =java.util.BitSet=, it was obviously not
designed for that purpose.
> That's why I propose to use an interface instead. The default implementation could still
delegate to =java.util.BitSet=.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message