lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doron Cohen (JIRA)" <>
Subject [jira] Commented: (LUCENE-664) [PATCH] small fixes to the new scoring.html doc
Date Sat, 30 Sep 2006 04:53:21 GMT
    [ ] 
Doron Cohen commented on LUCENE-664:

Hi Grant, 

For part 1, I am ok with having it after the scoring formula.

For part 2, my motivation was to make it more clear in:
  - - what's inside the sum and what's outside (as you said).
  - - what's decided at indexing time and what's still controllable at search time.
  - - how boosts and encoding/decoding play in.
  - - what's fixed and what can be modified, by subclassing, say, DefaultSimilarity.

So {indexBoost, searchBoost, normalizer} were the tools to clear this up, and also to make
the formula shorter and easier to read in a glance.

Naturally, after delving so deep into it is now clear to me, but you are right, it would be
good to hear from others how they like this part.


> [PATCH] small fixes to the new scoring.html doc
> -----------------------------------------------
>                 Key: LUCENE-664
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Website
>    Affects Versions: 2.0.1
>            Reporter: Michael McCandless
>         Attachments: boosts_plus_scoring_formula.patch, lucene.uxf, scoring-small-fixes.patch,
scoring-small-fixes2.patch, scoring-small-fixes3.patch
> This is an awesome initiative.  We need more docs that cleanly explain the inner workings
of Lucene in general... thanks Grant & Steve & others!
> I have a few small initial proposed fixes, largely just adding some more description
around the components of the formula.  But also a couple typos, another link out to Wikipedia,
a missing closing ), etc.  I've only made it through the "Understanding the Scoring Formula"
section so far.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message