lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Engels" <reng...@ix.netcom.com>
Subject RE: Results (Re: Survey: Lucene and Java 1.4 vs. 1.5)
Date Tue, 20 Jun 2006 14:35:33 GMT
To set the record straight, I think the Lucene product and community are
fantastic. Period.

I was also not the one who starting in with what could be termed
'aggressive' language.

Our company does not fully support 1.5. I was the loudest voice against the
move to 1.5.

After almost 2 years I now back the move. Why? Several reasons:

1. Sun is very slow, if at all to fix bugs in 1.4 (of which there are many).
For example, the current problems in Lucene regarding ThreadLocals. Although
this is not a bug per se, it is probably not intuitive or desired behavior.
The Lucene developers have been forced to both diagnose and create
workarounds "problems" already fixed in 1.5. The licensing of Java does not
allow for the easy fix bugs by non-Sun developers.
2. The type safe collections are far more efficient to program/debug with.
3. The standardized concurrent facilities can be of great benefit to
multithreaded programs.
4. It is what students graduating from college understand and use.
5. It is what the currently available books explain and use.

It just seems that many people believe that if there is ONE person (or a
minority) that can't switch, then Lucene cannot switch. It seems that Bob is
in this category of never being able to switch (I am fairly certain 1.5 will
probably never be released for OS 9) - does that mean that Lucene developers
can never use 1.5 features? What about the argument I made of using
alternative algorithms that may not be as useable on older, slower machines.

We have users that cannot upgrade to the latest release of our software
because of inadequate hardware (or unwillingness to change). They have 3
choices. Stick with the old, upgrade their machines, or move to a
competitor. The last of which we surely do not want, but that is their
choice. At the same time, if we did not continue to grow and evolve our
software, we would lose far more of our customers to competitors.

This is open-source software. A clear majority has voted. Why can't we
listen to them and move forward???

-----Original Message-----
From: Dan Armbrust [mailto:daniel.armbrust.list@gmail.com] 
Sent: Tuesday, June 20, 2006 8:42 AM
To: java-dev@lucene.apache.org
Subject: Re: Results (Re: Survey: Lucene and Java 1.4 vs. 1.5)

Robert Engels wrote:

> 
> People making these arguments against 1.5 sound really ill-informed, 
> or lazy. Neither of which is good for open-source development.
> 

Preface - I'm not a lucene developer - just an interested user.

I don't know - it seems to me that it is the 1.5 crowd that is making the
lazy argument.  You are in effect, saying, that the highly skilled
developers who would be making lucene contributions are unable or unwilling
to write 1.4 java code?  Come on... it really not that hard. 
Which set is being lazy?  I'll stop the name calling now, and try to make a
better point.

I have some applications that I have written in 1.5 - and yes - it is nice.
But I also have other applications (that use Lucene) that are written to be
1.4 compatible.  And they need to stay that way for quite some time to come.
Why?  Many reasons.  The first - because they implement an official HL7
specification - and the specification says that the implementation needs to
support Java 1.4.

Also, at my place of employment we have about 40,000 desktop computers that
are all centrally managed - down to every point release of every single
piece of software.  There are multiple applications using java that are
installed on these machines.  Each application has to be certified and fully
tested with a newer version of java before a newer version of java can be
installed.  As you can imagine, that severely hampers the pace of java
updates.  We are just getting 1.4 installed on these machines now.  When you
are managing that many machines in a clinical environment - you have to play
it safe.  There are no upgrades for an upgrades sake, or for syntactic
sugar.  There has to be a real problem to even get the process started.  I'm
sure many other people have similar situations.

Also - I don't know much about the Java mobile platform - but I thought I
had read before that they are limited to the 1.3 or 1.4 feature set? 
If this is true, do we really want to remove an entire ecosystem of
potential users?  Over syntactic sugar?

While I'm not completely opposed to the argument that I should just have to
stay with the Lucene 2.0.x release with applications that need to run in 1.4
environments - Lucene is an integral part of that code.  If performance
improvements are made to the core, I want those in my code. 
  If bugs are found and fixed - I want those fixes too.  As a matter of fact
- until the 2.0 release, I was using a build from the trunk because of a bug
that I found in Lucene, (and someone else was gracious enough to fix for
me).  Lucene is a low level library that is used to build many great
applications.  If you make the jump to 1.5 today - you are going to be
leaving people behind.  And judging by the poll, you are going to be leaving
a fairly significant number of people behind. 
Lucene has great policy on not breaking backwards compatibility in their API
- why should this be looked at any differently?

 > Rather than having the 1.5 developers having to waste their time  >
"thinking" in 1.4 when their work is predominately being performed  > using
1.5 features/compilers/tools.


I don't think that the caliber of developers that are working on the Lucene
core are going to be slowed down any by using 1.4 syntax over 1.5.  (It
actually takes longer to type in all of those generics :)  All of my tools -
Eclipse and Java 1.5 - have a check box that will cause them to generate 1.4
compatible code.  Its really _not_ a big deal to write 1.4 code even if you
are used to 1.5.  This particular argument just isn't compelling to me.


My personal opinion for the path that Lucene should take:

Core bugs fixes must be 1.4 compatible.
Core improvements must be 1.4 compatible.
Contrib / sandbox can be 1.5 or 1.6.

Of course, at some point - Lucene Core does need to advance.  But I don't
just don't feel that syntactic sugar in 1.5 is enough of a reason to break
backwards compatibility.  I haven't followed 1.6 - I don't know what the new
features are there.  Assuming that there are great new features in 1.6 -
that would improve the lucene core if they were used -
  I think that that is when this issue gets revisited.

This isn't the type of question that should be decided by a poll.  This
should be decided by thoughtfully looking at the consequences of each
choice.  For me - the negative consequences of choosing 1.5 - leaving behind
a lot of users - is much worse than the negative consequences of staying at
1.4 - making a couple dozen highly skilled developers check an extra box in
their lucene development environments?

If any developers have actually read this far (sorry - it got kind of
long) - thanks again for all of your great work - Lucene is a great tool
- and a great community.

Dan

--
****************************
Daniel Armbrust
Biomedical Informatics
Mayo Clinic Rochester
daniel.armbrust(at)mayo.edu
http://informatics.mayo.edu/

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message