lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Willnauer" <simon.willna...@googlemail.com>
Subject Re: Lucene and Java 1.5
Date Mon, 29 May 2006 18:46:13 GMT
So I guess that would be totally alright to build the gdata server 1.5
dependent.
does anyone feel comfortable with that?

simon

On 5/29/06, Erik Hatcher <erik@ehatchersolutions.com> wrote:
> To weigh in with my take, all environments I develop and deploy to
> are at JDK/JRE 1.5.  Solr is exclusively for 1.5+ and it has top
> billing my architecture.  GData server at 1.5 is perfectly fine by
> me.  I'd use it, and very interested in Solr collaboration as well.
>
>         Erik
>
>
> On May 29, 2006, at 11:30 AM, Simon Willnauer wrote:
>
> > I guess this discussion isn't over...
> > I would like to know if anybody would feel uncomfortable with a 1.5
> > dependend contrib project like the GData Server?
> >
> > I'm not sure whether it is worth to think about a 2.0 / 2.1 (tiger)
> > branch. That would be a lot more work but far less fight ;)
> >
> > simon
> >
> > On 5/29/06, Bill Janssen <janssen@parc.com> wrote:
> >> Boy, I'd sure like to see at least one bug-fix release for 2.0
> >> maintain java 1.4 compatibility.  Would that be 2.1?
> >>
> >> Bill
> >>
> >> > This sounds reasonable to me.  I feel bad about Andi and
> >> PyLucene, but it sounds like GCJ(X) will soon be up-to-date (the
> >> link Andi sent was from early February).  Discussion done or?
> >> >
> >> > Otis
> >> >
> >> > ----- Original Message ----
> >> > From: Chris Hostetter <hossman_lucene@fucit.org>
> >> > To: java-dev@lucene.apache.org
> >> > Sent: Saturday, May 27, 2006 7:12:15 PM
> >> > Subject: Re: Lucene and Java 1.5
> >> >
> >> > : important new facilities. Repeating my earlier question, why
> >> should a
> >> > : platform that is 2 years behind for java expect to be at the
> >> latest and
> >> > : greatest level for lucene? I'd propose 2.0 (+ branched
> >> patches) be the
> >> > : 1.4 release distribution, with 2.1 free to move up to 1.5.
> >> >
> >> > I would ammend that proposal slightly...
> >> >
> >> > 1a) Lucene Core 2.0.* releases garuntee java1.4 compatibility
> >> > 1b) Lucene Contrib modules in 2.0.* releases are free to require
> >> any java
> >> >     version they choose.
> >> >
> >> > 2a) Lucene Core 2.1.* release garuntee java1.5 compatibility.
> >> > 2b) Lucene Contrib modules in 2.1.* releases are free to require
> >> any java
> >> >     version they choose.
> >> >
> >> > -Hoss
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> >> For additional commands, e-mail: java-dev-help@lucene.apache.org
> >>
> >>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>
Mime
View raw message