lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@osafoundation.org>
Subject Re: Lucene and Java 1.5
Date Sat, 27 May 2006 18:21:12 GMT

On Sat, 27 May 2006, Yonik Seeley wrote:

> On 5/27/06, Daniel Naber <lucenelist2005@danielnaber.de> wrote:
>> If someone wants to add 1.5-dependent modules to
>> the contrib area that would be okay for me though.
>
> +1
>
> As far as Java1.4 or Java1.5 for Lucene core,  I agree that it would
> almost be nicer for developers than users.  Maybe we should try and
> get a feeling for how many people this might inconvenience...
>
> So is there anyone that can run on Java1.4 but can't run on Java1.5?
> I understand legacy situations, but surely anyone doing a major Lucene
> upgrade can upgrade the JVM at the same time (the performance boosts
> alone are worth it.)

As long as gcj is not implementing the new language features in 1.5, I'm stuck 
with 1.4. If the Lucene core started using 1.5-only features, I'd have to 
create more and more patches for PyLucene to still build and stay current with 
Java Lucene.

Andi..

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message