lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Engels" <reng...@ix.netcom.com>
Subject RE: Lucene and Java 1.5
Date Tue, 30 May 2006 20:38:03 GMT
1.5 has built in Logging support - eliminating the need for Jakarta logging.

That is like saying Jarkarta Collections does not use JDK 1.5. No one that
develops NEW software uses Jakarta Collections - they use the Collections
support in the JDK.
 

-----Original Message-----
From: Doug Cutting [mailto:cutting@apache.org] 
Sent: Tuesday, May 30, 2006 3:30 PM
To: java-dev@lucene.apache.org
Subject: Re: Lucene and Java 1.5

For reference, it appears that Ant encourages Java *1.2* compatibility. 
  Tomcat 5.5 does not yet support Java 1.5 language features in jsp pages,
but is now using Java 1.5 features internally.  Jakarta Commons Logging's
current release is still compatible with Java 1.2.  From what I can tell,
Jakarta HTTPClient still does not use Java 1.5 features. 
 From this small sample, it is tempting to generalize: libraries that are
built into other applications upgrade to new versions of Java more slowly
than full applications.

Doug

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message