lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Williams <ch...@manawiz.com>
Subject Re: Lucene and Java 1.5
Date Sat, 27 May 2006 19:41:51 GMT
Another issue concerns user contributions of patches and enhancements. I
have a significant body of code that might be contributed, all in 1.5,
to do things that have been requested by others who participate in the
lists. As most of the development community is using 1.5 now, Lucene may
get fewer good user contributions if it insists on keeping the core in
the dark ages of 1.4. 1.5 is a major improvement in Java development.
This will benefit the API's as well as the implementation. If 2.1+ is
the platform for new api's and functionality, it is will be an
impediment for both of these reasons to restrict it to 1.4.

Chuck

Chris Hostetter wrote on 05/27/2006 09:21 AM:
> : idea to think about using the 1.5 platform in future development. What's
> : about using the 1.5 platform as a requirement on new projects like the
> : contrib GDATA Server? We gonna have the same problem with the Gdata
>
> someone mentioned the idea that contrib packages should be free to
> use/require 1.5 ... i haven't seen any objection to that.
>
> the build files would need to be reworked slightly, but that's not a
> blocker issue.
>
>
>
> -Hoss
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message