lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: Lucene and Java 1.5
Date Tue, 30 May 2006 14:52:37 GMT
Just use 2.0.* for GCJ.
New Lucene releases are made every half a year at best.  It will be a while before we have
2.1.  By that time GCJ may be up to speed.

Otis

----- Original Message ----
From: Bill Janssen <janssen@parc.com>
To: java-dev@lucene.apache.org
Cc: Otis Gospodnetic <otis_gospodnetic@yahoo.com>
Sent: Monday, May 29, 2006 11:17:04 PM
Subject: Re: Lucene and Java 1.5 

My concern is really with the use of GCJ with Lucene.  I'd hate to see
Lucene core releases that couldn't be used with the latest "stable"
release of GCJ.  Unfortunately, it's very hard to know what that
means.  What's the latest version of GCJ?  What Java language features
are supported in it?  It's impossible to tell from the GCJ home page.

Bill

> : Boy, I'd sure like to see at least one bug-fix release for 2.0
> : maintain java 1.4 compatibility.  Would that be 2.1?
> 
> : Could be 2.0.*.  I think that is what Hoss was saying, too.
> 
> Yes, that was my point ... as far as i can tell, Lucene bug fix releases
> have historically been at the "third level" of the release number: 1.4.1,
> 1.4.2, and 1.4.3 were all bug fixes on the 1.4 release branch.  1.9.1 was
> a bug fix on the 1.9 release branch.
> 
> I'm suggesting there may be any number of 2.0.X bug fixing releases on the
> 2.0 branch which will all be java1.4 compatible.





---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message