lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Elschot <paul.elsc...@xs4all.nl>
Subject Re: A problem running two or more negative Span clauses
Date Fri, 05 May 2006 08:15:57 GMT
On Monday 01 May 2006 20:17, Chris Hostetter wrote:
> 
> :   I am having problems running span queries with more than one
> : negative clauses:
> 
> i believe you mean when the exclude clause contains a SpanNear query
> correct?
> 
> : Is the span query nested correctly?
> 
> I'm not very good at reading SpanQuery.toString() output ... but i believe
> i encountered the same bug independently over the weekend.  I just filed
> it this morning (once i had a chance to consult LIA and verify how a
> SpanNot was suppose to work)
> 
> http://issues.apache.org/jira/browse/LUCENE-560

This could be a duplicate of an earlier bug concerning SpanNotQuery.
There is a fix in jira, but not yet in the trunk. I can't connect to 
issues.apache.org at the moment,  but one could try later and search for
SpanNotQuery in jira for the fix.
Iirc the fix was about initializing one of the Spans used by the SpanNotQuery.

Regards,
Paul Elschot



> 
> 
> -Hoss
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
> 
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message