lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <>
Subject Re: compatibility of Lucene 1.9
Date Wed, 09 Nov 2005 03:28:34 GMT
It's almost impossible to maintain 100% compatibility... I think the
current level of compatibility is pretty good.

I ran into a couple of minor things myself when upgrading to Lucene 1.9:
  - writeLogTimeout and commitLockTimeout are now final, so they can't
be changed.
  - I have a class that extends Searcher, and there were new methods
added to Searchable which means I had to implement those new method
before my class would compile.

This is expert level stuff, the needed changes took me 10 minutes, and
one one should deploy a new version without thorough testing anyway
(it's a years worth of changes, after all).

Now hiring --

On 11/8/05, Erik Hatcher <> wrote:
> Daniel,
> Thanks for clarify it, sorry for asking before I got to your
> explanation.  Are there other known incompatibilities?
>      Erik

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message