lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: Version 1.9
Date Sun, 18 Sep 2005 08:38:32 GMT

On Sep 18, 2005, at 3:41 AM, Jeff Breidenbach wrote:
> 1) Does it make sense for Linux distributions to ship
> Lucene 1.9, or simply wait for 2.0? (I'm thinking 2.0...)

1.9 deprecates a lot of API, and 2.0 will be the same version with  
all the deprecated stuff removed.  So if folks jump straight from  
1.4.3 to 2.0 they may be frustrated when their applications do not  
compile.  Our recommendation is for developers to first compile  
cleanly with 1.9, then migrate to 2.0.

Perhaps Linux should ship with both 1.9 and 2.0?

     Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message