lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35822] New: - Escaping special characters in Query doesn't return correct results.
Date Thu, 21 Jul 2005 17:28:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35822>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35822

           Summary: Escaping special characters in Query doesn't return
                    correct results.
           Product: Lucene
           Version: 1.4
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Search
        AssignedTo: java-dev@lucene.apache.org
        ReportedBy: knsathya@hotmail.com


I was using the sample code available with the download and I added in two files:

FileOne with text: tina
FileTwo with text: ~tina

I was trying the Searcher.java (sample code) and trying to search for "\\~tina"
(match only documents containing the exact text ~tina). And lucene always
reports hits in both the documents.

I tried Standard, Simple and Whitespace Analyzers with the QueryParser and with
all of them the result is the same.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message