lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Stephen" <cstep...@htinc.com>
Subject RE: Error Initializing an FSDirctory - disableLuceneLocks is null (FollowUp)
Date Mon, 06 Jun 2005 19:03:31 GMT
The error we get is NoClassDefFoundError at
org.apache.lucene.index.IndexReader.open(IndexReader.java:95);  It's
breaking because the method that gets the disableLuceneLocks is
returning null, but here's the weird thing.  The product has been
running 7x24 for the last 6 months without any problem.  This error
cropped up when we repackaged the class we were using to wrap the Lucene
classes.  Currently we are manually setting the parameter in the code
but I'm trying to figure out how we've been able to use the class
without setting this parameter in the first place.

-----Original Message-----
From: Bernhard Messer [mailto:bmesser@apache.org] 
Sent: Monday, June 06, 2005 11:17 AM
To: java-dev@lucene.apache.org
Subject: Re: Error Initializing an FSDirctory - disableLuceneLocks is
null (FollowUp)

Craig,

what kind of error did you get when initializing FSDirectory ? The fact 
that Boolean.getBoolean("disableLuceneLocks") returns false or that the 
system property "disableLuceneLocks" is null is not an error. It  will 
be null, as long as you do not specify the system parameter with  
-DdisableLuceneLocks=true or -DdisableLuceneLocks=false during startup. 
The other case where disableLuceneLocks is set to true is running the 
software on a JVM version 1.1.x. So the documentation is ok when it says

that per default disableLuceneLocks is false.

Bernhard

Craig Stephen wrote:

>We've been getting an error when trying to initialize an FSDirectory.
>It's on line 48 of the FSDirectory source file.  The system property
>disableLuceneLocks is null.  Now we could set this manually, but it was
>working up until about a week ago when we moved our Lucene Wrapper
class
>to a new package.  How is the system property for disableLuceneLocks
>normally set? Has anyone had this problem before? 
>
> 
>
>According to the documentation, if you don't set disableLuceneLocks, it
>should default to false which is what we want.  Any suggestions would
be
>appreciated.
>
>PS.
>We are currently using Lucene 1.4.3.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
>For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message