lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: lucene 2.0?
Date Wed, 20 Apr 2005 01:15:25 GMT
On Apr 19, 2005, at 6:16 PM, Doug Cutting wrote:
> Bernhard Messer wrote:
>> I'm not a fan of outdated software or historical systems. So i think 
>> the best would be to keep lucene still backward compatible with 
>> version 1.9 and perform the switch to JDK 1.4 with lucene 2.0.
>
> That sounds like a good plan.
>
> Which raises the question, when should we make the 1.9 and 2.0 
> releases?
>
> The plan for these is at:
>
> http://wiki.apache.org/jakarta-lucene/Lucene2Whiteboard
>
> We should probably make these releases before we finish everything on 
> that list.  There have been a lot of good changes since 1.4.3 that 
> would be nice to get into more folks hands.
>
> Thoughts?

I'm all for a 1.9 release, let that stabilize and shake out any 
backwards compatible issues we may have missed, and then push out the 
2.0 as planned with all the deprecated API removed.  I'm using trunk 
for all my work, and many of the contrib components have been updated 
in trunk to the latest non-deprecated API - so someone using 1.4.3 
wouldn't be able to use the spellchecker from trunk, for example.

I will bump the build refactorings up in priority so that we can have 
all the contrib pieces bundled in as well, including javadoc 
integration.  I'll aim for the end of the coming weekend to have that 
in place.

	Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message