lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Elschot <paul.elsc...@xs4all.nl>
Subject Re: DO NOT REPLY [Bug 32965] - [PATCH] Use filter bits for next() and skipTo() in FilteredQuery
Date Mon, 04 Apr 2005 17:41:06 GMT
On Monday 04 April 2005 11:36, Erik Hatcher wrote:
> Oh, and one other thing.... Paul's code relies on JDK 1.4's assert  
> keyword.  It seems this is an unnecessary reason to jump to 1.4  
> dependence.
> 
> What do folks think about JDK 1.4 as a minimum Lucene requirement?

The FilteredQuery as posted there requires jdk 1.4
because it uses BitSet.nextSetBit():

http://issues.apache.org/bugzilla/show_bug.cgi?id=32965#c2

Regards,
Paul Elschot



---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message