lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [Jakarta Lucene Wiki] Updated: LuceneFAQ
Date Mon, 03 Jan 2005 21:26:07 GMT
   Date: 2005-01-03T13:26:06
   Editor: DanielNaber
   Wiki: Jakarta Lucene Wiki
   Page: LuceneFAQ

   updates and fixes

Change Log:

@@ -20,7 +20,7 @@
 ==== What Java version is required to run Lucene? ====
-Lucene will run with JDK 1.1.8 and up. (???)
+Lucene will run with JDK 1.3 and up but requires at least JDK 1.4 to compile.
 ==== Will Lucene work with my Java application? ====
@@ -122,7 +122,7 @@
 ==== Is the QueryParser thread-safe? ====
-Yes, `QueryParser` is thread-safe.  Its static `parse` method creates a new instance of `QueryParser`
each time it is called. (??? so is it thread safe only for the static method?)
+No, but !QueryParser's static `parse` method is thread-safe as it creates a new instance
of !QueryParser each time it is called.
 ==== How do I restrict searches to only return results from a limited subset of documents
in the index (e.g. for privacy reasons)? What is the best way to approach this? ====

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message