lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lucene-...@jakarta.apache.org
Subject [Jakarta Lucene Wiki] Updated: Lucene2Whiteboard
Date Sat, 13 Nov 2004 12:30:56 GMT
   Date: 2004-11-13T04:30:55
   Editor: DanielNaber <daniel.naber@t-online.de>
   Wiki: Jakarta Lucene Wiki
   Page: Lucene2Whiteboard
   URL: http://wiki.apache.org/jakarta-lucene/Lucene2Whiteboard

   no comment

Change Log:

------------------------------------------------------------------------------
@@ -14,7 +14,7 @@
 
  3. DONE: Replace public IndexWriter fields (mergeFactor, minMergeDocs, etc.) with get/set
accessors.  Also, minMergeDocs should be renamed maxBufferedDocs.
 
- 4. MOSTLY DONE: Rename PhrasePrefixQuery to be something like MultiPhraseQuery.  Also make
MultipleTermPositions a private nested class of this, as this is the only place MultipleTermPositions
is used.
+ 4. DONE: Rename PhrasePrefixQuery to be something like MultiPhraseQuery.  Also make MultipleTermPositions
a private nested class of this, as this is the only place MultipleTermPositions is used.
 
  5. DONE: Rename InputStream to IndexInput and OutputStream to IndexOutput. Also add BufferedIndexInput
and BufferedIndexOutput as the implementation used by FSDirectory, RAMDirectory, etc.  This
would permit unbuffered and native implementations (e.g., that use mmap) that could potentially
speed things considerably.
 
@@ -30,7 +30,7 @@
 
  11. (Hard) Make indexing more flexible, so that one could e.g., not store positions or even
frequencies, or alternately, to store extra information with each position, or to even use
different posting compression algorithms.  This could be implemented by extending Field to
specify a FieldIndexer.  A FieldIndexer would be passed each token and decide what about it
to record, how to record it, etc.  All fields with the same name must use the same FieldIndexer
implementation.  The FieldIndexer implementation would be serialized with the index.  Detailed
specification of a FieldIndexer API is required before this proposal can be seriously considered.
 
- 12. Modify MultiFieldQueryParser so that it behaves as most people expect: searching for
A AND B in the fields body, title means that both terms must occur, but it doesn't matter
whether they occur in title or body. The old behaviour must still be available by default
so we stay compatible.
+ 12. In PROGRESS: Modify MultiFieldQueryParser so that it behaves as most people expect:
searching for A AND B in the fields body, title means that both terms must occur, but it doesn't
matter whether they occur in title or body. The old behaviour must still be available by default
so we stay compatible.
 
  13. Deprecate PorterStemFilter, in favor of the Snowball analyzers.  This should also coincide
with folding the Snowball codebase into the main Lucene CVS tree (to be built as a separate
JAR but released with the main Lucene distributions).
 

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message