lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Janssen <jans...@parc.com>
Subject 1.4.2 breaks NewMultiFieldQueryParser by re-writing args list of getFieldQuery()
Date Tue, 02 Nov 2004 16:46:11 GMT
It looks like 1.4.2 quietly broke the API exported by 1.4.1, which my
NewMultiFieldQueryParser depended on.  In particular, the Analyzer
argument to getFieldQuery disappeared.

Now, you folks shouldn't do this in a micro-release.  Just add the new
method, without removing the old one.

And, if you do do it, you should note it in the CHANGES.txt file.

And, if you do do it, you should have a way of detecting which version
of Lucene is being used, so that developers can cope at configure
time.  Is there such a way?  An easy command-line test to tell the
1.4.1 jar file from the 1.4.2 jar file?

Bill

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message