lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lucene-...@jakarta.apache.org
Subject [Jakarta Lucene Wiki] Updated: Lucene2Whiteboard
Date Sun, 10 Oct 2004 18:39:30 GMT
   Date: 2004-10-10T11:39:30
   Editor: DanielNaber <daniel.naber@t-online.de>
   Wiki: Jakarta Lucene Wiki
   Page: Lucene2Whiteboard
   URL: http://wiki.apache.org/jakarta-lucene/Lucene2Whiteboard

   no comment

Change Log:

------------------------------------------------------------------------------
@@ -14,7 +14,7 @@
 
  3. Replace public IndexWriter fields (mergeFactor, minMergeDocs, etc.) with get/set accessors.
 Also, minMergeDocs should be renamed maxBufferedDocs.
 
- 4. Rename PhrasePrefixQuery to be something like MultiPhraseQuery.  Also make MultipleTermPositions
a private nested class of this, as this is the only place MultipleTermPositions is used.
+ 4. MOSTLY DONE: Rename PhrasePrefixQuery to be something like MultiPhraseQuery.  Also make
MultipleTermPositions a private nested class of this, as this is the only place MultipleTermPositions
is used.
 
  5. DONE: Rename InputStream to IndexInput and OutputStream to IndexOutput. Also add BufferedIndexInput
and BufferedIndexOutput as the implementation used by FSDirectory, RAMDirectory, etc.  This
would permit unbuffered and native implementations (e.g., that use mmap) that could potentially
speed things considerably.
 

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message