lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "René Hackl" <rene.a.ha...@gmx.de>
Subject Re: Failure of wildcard search in the middle of a term
Date Mon, 18 Oct 2004 08:21:28 GMT
Does your analyzer employ stemming? Maybe the ending gets ripped off and the
word is indexed as 'calgarian' or even 'calgar'.

Did you write the Analyzer yourself? I can't find it in any package to see
whether it does stem tokens...

Best Regards,
René



> I am using Lucene 1.4.1, I have indexed a PDF document.
> 
>   
> <http://www.calgary.ca/docgallery/bu/finance/Striking_A_Balance_Web.pdf>
http://www.calgary.ca/docgallery/bu/finance/Striking_A_Balance_Web.pdf 
> 
> In the document there is the word Calgarians. 
> 
> A search of Calgarians finds the document.
> 
> A search of Calgar* finds the document.
> 
> A search of Cal*s finds nothing. 
> 
> Using a standard query parser and an AliasAnalyzer , I know I have used
> the wildcard in the middle of a search string before and it returned
> documents. Is anyone else having this issue? or does anyone have an idea
of the
> cause?  No errors are occurring just no results are being returned.  
> 
> 

-- 
GMX ProMail mit bestem Virenschutz http://www.gmx.net/de/go/mail
+++ Empfehlung der Redaktion +++ Internet Professionell 10/04 +++


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message