lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lucene-...@jakarta.apache.org
Subject [Jakarta Lucene Wiki] Updated: Lucene2Whiteboard
Date Thu, 16 Sep 2004 21:17:23 GMT
   Date: 2004-09-16T14:17:22
   Editor: DougCutting <cutting@apache.org>
   Wiki: Jakarta Lucene Wiki
   Page: Lucene2Whiteboard
   URL: http://wiki.apache.org/jakarta-lucene/Lucene2Whiteboard

   no comment

Change Log:

------------------------------------------------------------------------------
@@ -16,7 +16,7 @@
 
  4. Rename PhrasePrefixQuery to be something like MultiPhraseQuery.  Also make MultipleTermPositions
a private nested class of this, as this is the only place MultipleTermPositions is used.
 
- 5. Rename InputStream to IndexInput and OutputStream to IndexOutput. Also make both of these
interfaces and add BufferedIndexInput and BufferedIndexOutput as the implementation used by
FSDirectory, RAMDirectory, etc.  This would permit unbuffered and native implementations (e.g.,
that use mmap) that could potentially speed things considerably.  [ Doug will work on this
one. ]
+ 5. IN_PROGRESS: Rename InputStream to IndexInput and OutputStream to IndexOutput. Also make
both of these interfaces and add BufferedIndexInput and BufferedIndexOutput as the implementation
used by FSDirectory, RAMDirectory, etc.  This would permit unbuffered and native implementations
(e.g., that use mmap) that could potentially speed things considerably.
 
  6. DONE: Replace DateField with something that formats dates suitably for RangeQuery.
 

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message