lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <>
Subject Re: API cleanup for Field
Date Mon, 30 Aug 2004 16:59:14 GMT

--- Doug Cutting <> wrote:

> Otis Gospodnetic wrote:
> > I like short names, too, but maybe Field.Vector.NO will make
> somebody
> > think java.util.Vector.  How about Field.TermVector or
> Field.TVector,
> > or Field.TV?
> Field.TermVector seems redundant to me, and Field.TV too telegraphic.
>  I 
> think, in this context, the use of Vector is unambiguous.  Also,
> doesn't 
> everyone use ArrayList now instead of Vector?

You'd think so, but I still see people just use Vectors when they don't
want to bother thinking about synchronization issues. :( Don't we still
have Vectors in Lucene in a number of places?

> What do others think?

Field.Vector is fine by me, but those less familiar with Lucene may
first think java.util.Vector, even though that wouldn't work even


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message