lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: API cleanup for Field
Date Mon, 30 Aug 2004 16:42:51 GMT
I like short names, too, but maybe Field.Vector.NO will make somebody
think java.util.Vector.  How about Field.TermVector or Field.TVector,
or Field.TV?

Otis

--- Doug Cutting <cutting@apache.org> wrote:

> Daniel Naber wrote:
> > here's a patch to clean up the API as described by Doug:
> >
>
http://www.mail-archive.com/lucene-user%40jakarta.apache.org/msg08479.html
> 
> Daniel,
> 
> This looks great!  Thanks for this and all of the other wonderful
> work 
> you've done recently for Lucene.
> 
> > The static Field.UnStored/Keyword etc methods are not deprecated. I
> think 
> > these can be confusing (e.g. what exactly does UnIndexed mean -- I
> always 
> > have to look it up), but nobody is forced to use them so there's no
> reason 
> > to deprecate them.
> 
> If they're confusing and have a less-confusing alternative then we 
> should eventually remove them from the API, so we should deprecate
> them 
> now.  We should move entirely to the new enumeration-based
> contructors. 
>   Everything else should be deprecated.
> 
> > The only boolean left is the one for term vectors. Should we add
> another 
> > enumeration like TermVectorIndex.NO/YES/...? I know that there's a
> patch 
> > that adds position information to the term vectors. How does that
> fit in 
> > here?
> 
> I think we should also add an enumeration for vector indexing.  I
> like 
> keeping names shorter when possible, so I'd vote for something like 
> Field.Vector.YES, and Field.Vector.NO.  This parameter should be 
> optional, defaulting to Field.Vector.NO.
> 
> Thanks again,
> 
> Doug



---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message