lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Elschot <>
Subject Re:, Filter
Date Sun, 01 Aug 2004 09:57:12 GMT
On Friday 30 July 2004 23:29, Robert Engels wrote:
> I thought the next release we were change 'Filter' to an interface, with a
> definition
> interface Filter {
>    boolean accept(Document doc);
> }
> Is this not going to happen?

I don't know, I wasn't involved in that.

I'd rather have the BitSet in the current filter changed into a DocNrFilter
and leave the current filter as it is for backward compatibility. So how about:

interface DocNrFilter { /* new interface for BitSet, Set and other implementations */
  boolean accept(int docNr);

However, I'd like to have a bit some more functionality in there to support doc(), next()
and skipTo(), ie. document number iterator as needed by a Scorer.
It would a waste not to use BitSet.nextBitSet().

Thinking about it, the current FilteredQuery might be reimplemented using a 
FilteringQuery. I might give that a try one of these days.

(Rereading the posted I see that it doesn't compile
as it is, the constructor for class SkipReaderBitsScorer is
still named FilterReaderBitsScorer,  sorry.)


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message