lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Schuster <>
Subject RE: release & migration plan
Date Mon, 12 Jul 2004 17:33:49 GMT
Doug Cutting wrote:

> 3. Replace public IndexWriter fields (mergeFactor, minMergeDocs, etc.) 
> with get/set accessors.  Also, minMergeDocs should be renamed 
> maxBufferedDocs.

I'd also suggest changing the static field maxClauseCount in BooleanQuery to
use a getter/setter and eliminate the System.getProperty call (as in
IndexWriter). The System.getProperty calls prevent the use of Lucene as a
search engine in an unsigned applet.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message