lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: cvs commit: jakarta-lucene/src/java/org/apache/lucene/store FSDirectory.java Lock.java RAMDirectory.java
Date Mon, 10 May 2004 23:48:38 GMT
On May 10, 2004, at 5:44 PM, Doug Cutting wrote:
> ehatcher@apache.org wrote:
>>    public abstract class Lock {
>>      public static long LOCK_POLL_INTERVAL = 1000;
>>   +  private File lockFile = null;
>>   +    +  Lock(File lockFile) {
>>   +    this.lockFile = lockFile;
>>   +  }
>
> I think this should be "String lockName" rather than "File lockFile". 
> Locks need not be files.  Since this is only used for debugging, a 
> string is entirely appropriate.

Done.

	Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message