lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Cutting <cutt...@apache.org>
Subject Re: cvs commit: jakarta-lucene/src/java/org/apache/lucene/store FSDirectory.java Lock.java RAMDirectory.java
Date Mon, 10 May 2004 21:44:30 GMT
ehatcher@apache.org wrote:
>    public abstract class Lock {
>      public static long LOCK_POLL_INTERVAL = 1000;
>   +  private File lockFile = null;
>   +  
>   +  Lock(File lockFile) {
>   +    this.lockFile = lockFile;
>   +  }

I think this should be "String lockName" rather than "File lockFile". 
Locks need not be files.  Since this is only used for debugging, a 
string is entirely appropriate.

Doug

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message