lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hani Suleiman" <h...@formicary.net>
Subject Re: JDK compatibility (Collections API)
Date Wed, 08 Oct 2003 14:22:38 GMT
+1, is there a single coherent well-considered argument for supporting
1.1? It seems yet another one of those inexplicable apachisms ;)

Terry Steichen said:
> ----- Original Message -----
> From: "Matt Tucker" <matt@jivesoftware.com>
> To: "Lucene Developers List" <lucene-dev@jakarta.apache.org>
> Sent: Wednesday, October 08, 2003 10:03 AM
> Subject: Re: JDK compatibility (Collections API)
>
>
>> We've found that Lucene essentially requires JDK 1.3.1 or later
>> because  of some VM bugs in 1.3.0. Perhaps Lucene would also work with
>> 1.2.x VM's  (we haven't tested)? However, trying to preserve
>> compatability with  1.1.x seems just silly. It would be premature to
>> require JDK 1.4.x, but  virtually everyone uses 1.3 or 1.4. And, even
>> though some small few  don't, I don't think that's a good enough
>> reason to shackle Lucene to a  very old VM version. That's just my
>> opinion though. :)
>
> +1
>
> Regards,
>
> Terry
>
> --------------------------------------------------------------------- To
> unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-dev-help@jakarta.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message