lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 23964] New: - QueryParser fails when feeding with a stop word with a boosting factor
Date Tue, 21 Oct 2003 08:52:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23964>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23964

QueryParser fails when feeding with a stop word with a boosting factor

           Summary: QueryParser fails when feeding with a stop word with a
                    boosting factor
           Product: Lucene
           Version: 1.2rc5
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Enhancement
          Priority: Other
         Component: QueryParser
        AssignedTo: lucene-dev@jakarta.apache.org
        ReportedBy: pakozdi.tibor@freemail.hu


so this happens when I use the StandardAnalyzer which contains StopFilter

in most of the case the parser autoatically removes the stop words, as one can
check at the official demo, found at
lucene-1.2/src/demo/org/apache/lucene/demo/SearchFiles

this only fails when there is a boosting factor defined for any of the stop
word,. like this: the^3

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message