lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tatu Saloranta <>
Subject Re: JDK compatibility (Collections API)
Date Thu, 09 Oct 2003 00:56:18 GMT
On Wednesday 08 October 2003 08:03, Matt Tucker wrote:
> Tatu,
> We've found that Lucene essentially requires JDK 1.3.1 or later because
> of some VM bugs in 1.3.0. Perhaps Lucene would also work with 1.2.x VM's

I agree. 1.3 is also much better performance-wise than 1.2 (1.4 is even 
better, and has surprisingly nice improvements for core classes... HashMap 
for example is dead-on efficient at this point).

> (we haven't tested)? However, trying to preserve compatability with
> 1.1.x seems just silly. It would be premature to require JDK 1.4.x, but
> virtually everyone uses 1.3 or 1.4. And, even though some small few
> don't, I don't think that's a good enough reason to shackle Lucene to a
> very old VM version. That's just my opinion though. :)

I agree; I definitely wasn't arguing for 1.1 compatibility, just pointing out 
that perhaps some people would like that, and that it should be discussed. 
And if/when consensus is that 1.1 is moot point, then we can proceed knowing 
1.2 features can be fully used.

-+ Tatu +-

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message