lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tatu Saloranta <t...@hypermall.net>
Subject JDK compatibility (Collections API)
Date Wed, 08 Oct 2003 13:55:32 GMT
I think this has been briefly discussed in the past, but what is the consensus
on using parts of JDK API only available in releases later than 1.1.x?
I'm specifically thinking of Collections, which was introduced for 1.2.x 
(although was available as separate package for 1.1.x I believe).
I'm not sure if there already are other dependencies to 1.2.x, if so, what are 
those?

In general I think it is good idea to try to avoid having dependencies to 
newest releases, at least on core Lucene classes... but in case of 
Collections I'd really like to be able to use those classes.
What do others think?

Alternatively if 1.1.x compatibility really is a high priority, it's 
oftentimes possible to write wrappers and store them (say, Hits wrapper)
in different optional package.

What do others think?

-+ Tatu +-


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message