lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: [PROPOSAL] Add Lucene Distribution To Mirrors
Date Wed, 10 Sep 2003 10:49:29 GMT
On Wednesday, September 10, 2003, at 05:40  AM, Otis Gospodnetic wrote:
> I don't know the details, but I believe one needs accounts on servers
> other than the CVS one, etc.

We'll find a way to get the right privileges to do this soon.

> I think it would make sense to use version 3.0 of JavaCC, which is the
> latest version, I believe.

Yup, I'm using JavaCC 3.2.

> Hm, I think we should not demand from users to get alpha versions, etc.
> Does 1.5.4 (current stable release) have what it needs to have for
> JavaCC 3.0?

The patches from the issue you pointed to have a hack to make JavaCC 
3.x work with Ant 1.5.x.  But the latest codebase of Ant has this 
support already too.  Ant 1.6 will be out in the relatively near 
future, so we won't have to worry about this situation much longer - 
although maybe it would make since to just use <java> to call to the 
parser directly rather than use the <javacc> wrapper, making the build 
less brittle.

> I also see from Ant's home page that the new 1.6.* versions will
> require JDK 1.2 or later.  I think that is fine, I think we already
> require this for Lucene.

Right.  Requires JDK 1.2 to run the build, but it will still be able to 
target="..." to 1.1.

> See also:
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19468

Thanks!  Sorry I hadn't seen that one before.  I'll borrow from it to 
do what I need to get done.

	Erik


Mime
View raw message