lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <>
Subject Re: cvs commit: jakarta-lucene build.xml
Date Thu, 18 Sep 2003 19:00:35 GMT
On Thursday, September 18, 2003, at 02:18  PM, Doug Cutting wrote:
> wrote:
>>   More build file cleanup - making target names
>>   more sensible in an effort to start splitting the
>>   coupling between the demo, tests, and core.  Test
>>   target is now "test" ("test-unit" alias remains).
> While you're renaming build-related stuff, I'd vote to rename the 
> build directory "build" instead of "bin".

*whew* - glad we're on the same page here!  bin bugs me.  I'm trying to 
do this stuff slowly, gently, and without messing anyone up too much 
that is relying on things.

What I'll do is do things in Ant and build best practices way, but 
within reason.  I might do some things without asking, but I'm always 
open to input and doing things according to the group wishes.  So by 
all means feel free to question me or complain about anything I might 
do to the build process.

But rest assured, I know what I'm doing and won't break anything too 
awfully bad!  :) is going to go away eventually, and fold into 
build.xml (sorry, Jon) with capabilities to override things.  There are 
too many Ant properties that are unnecessary - this will be cleaned up 

I'll take my time - I won't let a release be built until all the unit 
tests pass anyway, so I have some time before we make a release 
probably :))


View raw message