lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19468] - Lucene 1.3-rc1 does not build against JavaCC 3.0
Date Sun, 15 Jun 2003 18:38:51 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19468>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19468

Lucene 1.3-rc1 does not build against JavaCC 3.0





------- Additional Comments From Eric.Isakson@sas.com  2003-06-15 18:38 -------
With the changes to the build files and the javacc3-ant-support.jar added to my 
lucene lib directory (both of these are attached to this bug), I am able to 
successfully build lucene's javacc files using the Ant integrated with Eclipse 
2.1 which is Ant 1.5.2

I have not tried the changes with any older versions of Ant.

The javacc3-ant-support.jar just contains a compiled copy of the JavaCC task in 
the main trunk of the Ant CVS renamed so the classloader can find it instead of 
the JavaCC task bundled with Ant. I then added a task definition 
called "javacc3" that uses the new class.

When Ant 1.6 is released, we can just remove the jar and task definition and 
change the javacc3 tasks back to javacc tasks and require Ant 1.6 to build 
Lucene's javacc files.

---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message