lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan LaPlante" <blapla...@netwebapps.com>
Subject Re: MultiSearcher vs IndexSearcher
Date Fri, 23 May 2003 06:25:35 GMT
never mind, I see what is happening. Only the second index is being searched
regardless of what order I put them in.

----- Original Message -----
From: "Bryan LaPlante" <blaplante@netwebapps.com>
To: <lucene-dev@jakarta.apache.org>
Sent: Friday, May 23, 2003 1:22 AM
Subject: MultiSearcher vs IndexSearcher


> Hi all,
>
> I am working on conditionally searching one or more indexes using an
> instance of IndexSearcher for searching a single index or using
> MultiSearcher, passing it an IndexSearcher[] array if searching multiple
> indexes.
>
> I created an index of the lucene docs and placed it in the
opt/lucene/index
> directory and I created an index of the tomecat-docs and placed it in the
> search/lucene/index directory.
>
> When I search opt/lucene/index for the word "class" I get 953 results.
When
> I include the search/lucene/index and search both using a MultiSearcher,
the
> same keyword returns 24 results. Why am I getting different results when
at
> least I should get the original 953 and possibly an additional 24.
>
> Any idea's?
>
> Bryan LaPlante
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-dev-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-dev-help@jakarta.apache.org


Mime
View raw message